hdu 1113 暴力以及map string的用法 这个比较帅重要

来源:岁月联盟 编辑:exp 时间:2012-08-28

Word Amalgamation
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1646    Accepted Submission(s): 758


Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
 

Input
The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words' that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

Sample Input
tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX
 

Sample Output
score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******
 
最重要的还是map的用法
 
题意:
输入字典  XXXXXX结束字典的输入  然后输入字符串  如果字符串能够组成字典中的串就输出该串 否则输出NOT A VALID WORD
输入XXXXXX结束改组数据输入
思路:把字典的每个串中的每个字符从小到大排序  询问串也是  然后原串与排序后的串作为一组添加进map 即可
 
暴力方法
[cpp]
#include <iostream> 
#include <algorithm> 
#include <stdio.h> 
#include <string.h> 
using namespace std; 
struct node 

    char s[10]; 
    char st[10]; 
    bool operator<(const node&b)const 
    { 
       return strcmp(s,b.s)<0; 
    } 
}rc[103]; 
int main() 

    char s[10]; 
    int i,n=0; 
    while(scanf("%s",s),strcmp(s,"XXXXXX")!=0) 
    { 
        strcpy(rc[n].s,s); 
        sort(s,s+strlen(s)); 
        //puts(s); 
        strcpy(rc[n].st,s); 
        n++; 
    } 
    sort(rc,rc+n); 
    int f; 
    while(scanf("%s",s),strcmp(s,"XXXXXX")!=0) 
    { 
        sort(s,s+strlen(s)); 
        f=0; 
        for(i=0;i<n;i++) 
          if(strcmp(rc[i].st,s)==0) 
            f=1,printf("%s/n",rc[i].s); 
        if(!f) 
        printf("NOT A VALID WORD/n"); 
        printf("******/n"); 
    } 
    return 0; 

[cpp] 
/*map的用法 很帅  string的用法  很帅*/ 
[cpp] 
#include<iostream> 
#include<stdio.h> 
#include<map> 
#include<string> 
#include<algorithm> 
using namespace std; 
map <string ,string > node; 
int main() 

    string s; 
    while(cin>>s&&s!="XXXXXX") 
    { 
        string t=s; 
        sort (s.begin(),s.end());//这个方法好帅  哥哥折服了 
        node.insert(pair<string,string>(t,s)); 
 } 
 while(cin>>s) 
 { 
  if(s=="XXXXXX") break; 
  int flag=1; 
  map<string,string>::iterator it; 
    sort(s.begin (),s.end ()); 
    for(it=node.begin ();it!=node.end();it++) 
    { 
     if(it->second==s) 
     { 
      flag=0;cout<<it->first<<endl; 
     } 
    } 
    if(flag) cout<<"NOT A VALID WORD"<<endl; 
    cout<<"******"<<endl; 
 } 
 return 0;